Swoole Compiler 安装向导

CeoMax-Pro主题需要swoole加密扩展,支持PHP7.2/7.3/7.4,推荐7.4


检查当前环境
  • 操作系统 : Linux wh-nbfr4xcmejv92gtotja-64d866f7bd-87vmg 4.19.91-21.al7.x86_64 #1 SMP Wed Sep 2 19:47:49 CST 2020 x86_64
  • PHP版本 : 7.4.16
  • PHP运行环境 : fpm-fcgi
  • PHP配置文件 : /data/php/php74/php.ini
  • PHP扩展安装目录 : /var/www/php/lib/php/extensions/no-debug-non-zts-20190902
  • PHP是否线程安全 : 非线程安全
  • 是否安装swoole_loader : 未安装

安装和配置Swoole Loader

1 - 点击下载 unix PHP7.4 Swoole Loader扩展文件

2 - 安装Swoole Loader

将刚才下载的Swoole Loader扩展文件(swoole_loader_74_nts.so)上传到当前PHP的扩展安装目录中:

/var/www/php/lib/php/extensions/no-debug-non-zts-20190902

3 - 修改php.ini配置(如已修改配置,请忽略此步骤,不必重复添加)

编辑此PHP配置文件:/data/php/php74/php.ini,在此文件底部结尾处加入如下配置

extension=swoole_loader_74_nts.so
注意:需要名称和刚才上传到当前PHP的扩展安装目录中的文件名一致

4 - 重启服务器

重启PHP或者重启服务器

最后刷新当前页面